Computer advice thread ("What's the best way to do this?")


#262

Whatever makes you happy, games for you and weird computer projects for me. :+1:


#263

I am in 0 rush. Enjoy your funsies. If I beat ya to it I’ll let ya know here as well.


#264

I have a problem that I’ve been trying to solve for a couple of weeks, dropping it here in case anyone’s dealt with it before.

I’m trying to create a location control system for my workplace, and decided that the simplest way was to put a barcode on each job that employees could scan with their phone. I even found an app that will allow me to pull up the barcode scanner with a weblink, so it’s just a basic webpage with a php script to update the database.

The problem is that this solution only works for Android. If I had a iDevice, I could test the programs in the app store, because I think there’s at least one app that built off this library.


#265

What you want to do is flip everything on its head.

Imagine you had fancy RFID instead of barcodes. What would you do? You wouldn’t give every employee an RFID reader and put an RFID at each location. That’s crazy. You put an RFID reader at each location and give an RFID to every employee.

And that is what you have to do with the barcodes. Give each employee a card with a barcode on it. Then put an Android device at each location. Now you don’t need to deal with iOS. You control the software on the devices. No need to worry about employees phones or anything. Just give out cards that can be easily reprinted.


#266

I accidentally clicked the speed button a few times while listening to this episode and got treated to what 90 year old Rym and Scott will sound like on geek nights.


#267

The reason why I built this to employee phones is I usually have trouble trying to get money for technology. Otherwise, I’d be looking at real barcode scanners and actual computers. Each employee using their own device is less likely to involve any cost or risk of loss.

Though I can try seeing if I can pick up a Fire Tablet (looks like its the cheapest tablet on the market).


#268

You can do this very very very inexpensively. Barcode readers are so cheap. You can even just get cheap webcams. You can get the oldest and most busted phones. There are so many options that are very low-cost.


#269

So, Just Cause 3, Fallout 4, and Civ VI are all crashing when I try to start them up without error message. The same does not happen for other games like Cuphead, Skyrim, and TF2. I tried updating my graphics, drivers, verifying the game files, rebooting, and redownloading Just Cause all together. All three of these games worked on this machine as recently as yesterday. I’m not aware of having done anything to change anything on this machine to cause this.


#270

Cuphead (1): works
TF 2: works
Just Cause 3: broken
Fallout 4: broken
Skyrim (elder scrolls 5): works
Civ 6: broken

Clearly this is significant. Do you have any games with 7 in the title to test?


#271

Unfortunately no.


#272

Well the non working games are all 3D and from the past 3 years, the other ones are old / 2D. Could be the newer games are calling something that’s missing or corrupted. Generally that means drivers or something but you already tried that.

Maybe download a few 3D tech demos and see if they run properly or not?


#273

I have Bioshock HD, it crashes if I have my tablet plugged in.

¯_(ツ)_/¯


#274

I plugged in an extra hard drive before things started crashing. Could that be it?

EDIT: I tried disconnecting the drive and it didn’t change anything.


#275

Make sure you have the latest DX stuff installed.

Are these running from an SSD? I had a similar problem on my laptop that ended up being the SSD itself hitting End-Of-Life and corrupting various files. The PC worked fine, but games or applications that would open a lot of files would run into strange issues and crash.

Try using steams Verify Game Files feature for the games and see if anything comes up. Look in the Windows Event Log for anything interesting around the times you try to launch the games.


#276

Running from an HDD. Already tried verifying the game files in Steam. DirectX is up to date. I’ve only had this computer for a few weeks so it really shouldn’t have any End-Of-Life issues.

EDIT: I checked the Event Log and found this error message: Faulting application name: JustCause3.exe, version: 0.0.0.0, time stamp: 0x5787669e
Faulting module name: dxgi.dll, version: 10.0.16299.98, time stamp: 0xc29ffbca
Exception code: 0xc0000005

EDIT2: Same problem with dxgi.dll with Fallout 4. What can I do about this?


#277

Was a program called reshade installed recently?

FWIW try this:

rename dxgi.dll to d3d11.dll
rename dxgi.ini to d3d11.ini


#278

It says I need permission from Trusted Installer to rename dxgi.dll.


#279

The computer won’t let you modify the files even with admin access.


#280

Now it says I need permission from me.


#281

I’ve come to the conclusion that I need to just reset the PC. Backing up my programs now.