The thread formerly known as "Weekend Coding"


#1

A thread for tracking projects (not necessarily digital in nature!) that you might be working on in your downtime/as a hobby.


#2

Back to working on my video game! Thought I’d do a video so people can see it in action. Most visible improvements are animations, some debug modes, minor but nifty dungeon gen techniques, and making your torch fade. every. step. you. take.


#3

On a whim I decided to make FizzBuzz in VHDL using only DFFs and combinational logic. Finding multiples through combinational logic is tough, so I wrote a Quine-McCluskey simplifier in Python to turn min-terms into VHDL. 10-12 work hours later it finally fucking works.


#4

@Andrew your game map reminds me of the Nethack gui version. I wish they would modernize it to look that nice.


#5

I hesitate to give any critique since I’m sure you’ve considered all this, but the hard shadows are sort of off-putting in contrast with the soft shadows illuminating the player character.


#6

I’ve been dicking around with Python and I came up with tuplecalc: a 4 function calculator that uses no data types but tuples both for internal logic and for I/O. () = 0, (()) = 1, ((())) = 2, etc. I’ll probably keep working on it for a bit to add even stupider functionality.


#7

You monster. I love it.


#8

I’ve been learning Haskell lately. It’s pretty fun.


#9

Ok, so I want to use my iPad pro for programming. Apparently this is how it is done:

You setup some OTHER computer with the development environment. Then you use the iPad pro as just a terminal client. This is actually kinda great for me, I want to do it.

Even better, there’s this mosh thing that is better for mobile usage than ssh. That sounds great!

Here’s the problem. It doesn’t support SSH Agent Forwarding. Also, I’ve recently learned that a lot of people really don’t like agent forwading.

https://heipei.github.io/2015/02/26/SSH-Agent-Forwarding-considered-harmful/

So here’s my question, though. You have your SSH Key on your iPad (or any computer). You connect to another machine where you are doing work via SSH/Mosh. Now you need to do git pull/push/clone. This also requires your SSH key to authenticate. Without agent forwarding, how the hell do you do this?

The only solution I can think of is to put ANOTHER separate SSH key on the remote server. That just seems really bad. Even worse than using agent forwarding. How the hell are people developing without this feature? How is there no secure solution to this basic problem?

This has been an issue in Mosh since 2012, and is still not solved. What a shame.


#10

The answer to your question as to how there is no solution is probably that the people that do development on ipads don’t use git.


#11

You don’t like having one ssh key for connecting to your dev environment from your iPad and then another ssh key for git? What’s the problem with that?

Did you try the patch?

Is mosh even helping you here? You’ve got high packet loss and latency sshing to your dev machine?


#12

I can’t patch software on my iPad.

You really think it’s safe to leave a key on a server, even if just for git? I might just have to do that.


#13

I’ve got an ssh key just for github, and another ssh key for my work desktop to my work dev environment, etc.

You can (and should) protect it with a password. It’s as safe as anything else and safer than using one key everywhere. ssh-agent is almost certainly already set up for you, so you can use ssh-add (better: ssh-add -t to set a lifetime) so that you don’t have to enter the password every time.


#14

Yes, I put a password on all my keys and know how to use the agent. I just feel like private key files should only exist on storage devices that I physically possess. Putting a private key file, even if it’s just for Git, onto a hosted server makes me feel meh. This is why I always used agent forwarding, despite its flaws.


#15

Advent of Code 2017 is live.


#16

Google’s doodle today was fun, in the GROW games kind of way. My (minimum step) solution to the last puzzle left me feeling dirty, though.


#17

Did we get different solutions? Mine felt pretty clean to me.


#18

Turns out I can’t even remember my solution.
Ok ((FRF)2L)5, I think. Lots of hopping against the wall.


#19

Is that how it works? I just assumed you fall off and never tried. That explains why it seemed impossible.


#20

Ah, it turns out Google’s official “shortest” solution was not the shortest possible for a few of the levels, so I’m guessing yours was one of the shorter (but ugly) ones.